#1363 new
Julien Le Goff

Cue point not triggered when playing fast-forward

Reported by Julien Le Goff | October 26th, 2012 @ 07:01 AM | in 1.4

When fast-forwarding a video using playbackRate, cue points are sometimes not triggered. The behaviour seems to be random. See this example:
http://jsfiddle.net/waCK4/ (try running it several times).

Comments and changes to this ticket

  • Rick

    Rick October 26th, 2012 @ 11:57 AM

    Confirmed. Increased playbackRate seems create scenarios where timeupdate isn't dispatched for whole seconds in the video ie. the media might jump from 1s to 3s between two seperate timeupdate events.

    Buggy: http://jsfiddle.net/rwaldron/v9xhf/

    Using the frameAnimation: true option avoids this

    Works: http://jsfiddle.net/rwaldron/v9xhf/9/

  • Rick

    Rick October 26th, 2012 @ 11:58 AM

    Just as I switched back to the tab running the "working" fiddle, I saw missed cues... back to the drawing board.

  • Scott Downe

    Scott Downe January 22nd, 2013 @ 05:50 PM

    I was talking about issues with cue recently as well.

    I think we need a finer grain of control specific to cue.

    We may need to have a 0 duration cue, so it is not a range, just a start, no end.

    If the an update time is >= to the time, and previously was <, and we're playing, we have a valid cue to fire.

    The "is playing" part is key, or you'll fire them on seeks too.

    Thoughts?

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Popcorn.js is an HTML5 video framework that lets you bring elements of the web into your videos.

Popcorn.js is a project of Web Made Movies, Mozilla's Open Video Lab.

Shared Ticket Bins

Pages